当前位置 博文首页 > 美迪的麦柯的博客:JavaA+B

    美迪的麦柯的博客:JavaA+B

    作者:[db:作者] 时间:2021-08-18 09:41

    第一周:
    仅提供Java简单代码:

    标题Problem A: A + B

    (Time Limit: 1 Sec Memory Limit: 128 MB)

    Description

    计算A+B

    Input

    输入数据有多组。每组输入数据包括两个整数A和B,A和B之间用空格分隔,每组输入占一行。

    Output

    对于每组输入数据,计算A和B的和并输出,每个输出占一行。

    Sample Input Copy

    1 5
    10 20

    Sample Output Copy

    6
    30

    Java代码:

    import  java.util.Scanner;
    public class Main {
        public static void main(String[] args) {
            Scanner input =new Scanner(System.in);
            int a,b;
            while(input.hasNext())
            {
             a=input.nextInt();
             b=input.nextInt();
            System.out.println(a+b);
            }    
        }
    }
    

    运行结果:

        Language: Java
        Result: Accepted
        Time:111 ms
        Memory:10144 kb
    

    标题Problem B: A + B

    (Time Limit: 1 Sec Memory Limit: 128 MB)

    Description

    计算A+B

    Input

    输入数据第一行包含一个整数N,接下来是N行。每行包括两个整数A和B,A和B之间用空格分隔。

    Output

    对于每组输入数据,计算A和B的和并输出,每个输出占一行。

    Sample Input Copy

    2
    1 5
    10 20

    Sample Output Copy

    6
    30

    Java代码:

    import  java.util.Scanner;
    
    public class  Main{    
        public static void main(String[] args) {
            Scanner input =new Scanner(System.in);
            int a,b,j;
            j=input.nextInt();
            for(int i=1;i<=j;i++)
            {
                a=input.nextInt();
                b=input.nextInt();
                System.out.println(a+b);
            }  
        }
    }
    

    运行结果:

        Language: Java
        Result: Accepted
        Time:110 ms
        Memory:10160 kb
    

    标题Problem C: A + B

    (Time Limit: 1 Sec Memory Limit: 128 MB)

    Description

    计算A+B

    Input

    输入数据有多组。每组输入数据包括两个整数A和B,A和B之间用空格分隔,每组输入占一行。当A和B都是0时输入结束。

    Output

    对于每组输入数据,计算A和B的和并输出,每个输出占一行。

    Sample Input Copy

    1 5
    10 20
    0 0

    Sample Output Copy

    6
    30

    Java代码:

    import  java.util.Scanner;
    
    public class Main {
        public static void main(String[] args) {
            Scanner input =new Scanner(System.in);
            int a,b;
            while(input.hasNext())
            {
                a=input.nextInt();
                b=input.nextInt();
                if(a==0&&b==0) 
                 {
                 break;
                 }
                System.out.println(a+b);              
            }
                 
        } 
    }
    

    运行结果:

        Language: Java
        Result: Accepted
        Time:107 ms
        Memory:10136 kb
    

    标题Problem D: 求和

    (Time Limit: 1 Sec Memory Limit: 128 MB)

    Description

    计算给定整数序列的和。

    Input

    输入数据有多组。每组输入数据包括一个整数N和N个整数,每个整数之间用空格分隔,每组输入占一行。当N为0时输入结束。

    Output

    对于每组输入数据,计算N个整数的和并输出,每个输出占一行。

    Sample Input Copy

    4 1 2 3 4
    5 1 2 3 4 5
    0

    Sample Output Copy

    10
    15

    Java代码:

    import  java.util.Scanner;
    
    public class Main {
        public static void main(String[] args) {
            Scanner input =new Scanner(System.in);
            int a,b,sum;
            while(input.hasNext())       
        	{ 
        	   	
          	sum=0;
          	b=input.nextInt();
            if(b==0)	
            {	
            break;	
            }
        	for(int i=1;i<=b;i++) 
            {
            a=input.nextInt();sum+=a;
            }
    		System.out.println(sum);
    		
        	}
    	}
    }
    

    运行结果:

     	Language: Java
        Result: Accepted
        Time:112 ms
        Memory:10172 kb
    

    END

    cs
    上一篇:没有了
    下一篇:没有了