当前位置 主页 > 服务器问题 > nginx问题汇总 > 最大化 缩小

    总结Nginx 的使用过程中遇到的问题及解决方案

    栏目:nginx问题汇总 时间:2018-10-20 16:35

    这篇文章主要总结了Nginx 的使用过程中遇到的问题及解决方案,非常的简单实用,以后遇到相关问题还会继续更新,希望大家收藏关注

    在启动 Nginx 的时候,有时候会遇到这样的一个错误:

    复制代码 代码如下:
    [emerg]: could not build the proxy_headers_hash, you should increase either proxy_headers_hash_max_size: 512 or proxy_headers_hash_bucket_size: 64

     解决办法就是在配置文件中新增以下配置项:
    复制代码 代码如下:
    proxy_headers_hash_max_size 51200;
    proxy_headers_hash_bucket_size 6400;

     这两个配置项的 size 根据系统后端发送的 header 来进行设置。

    注:默认值的话,就会上面出现上面那样出现错误
     
    Nginx 缓存刷新问题

    在使用 Nginx 的过程中,因为 Nginx 本地使用了缓存,然后发布了静态资源后, CDN 回源的时候,发现没有正常回源,经过查询发现,是因为 Nginx 本地有缓存,而有没有对缓存进行刷新的原因,要刷新本地缓存,可以安装 Purge 模块。

    Nginx 的缓存设置:
    复制代码 代码如下:
    location /
          {
           proxy_cache cache_go;
           proxy_cache_valid 200 304 1d;
           proxy_cache_key $host$uri$is_args$args;
           proxy_set_header Host  $host;
           proxy_set_header X-Forwarded-For  $remote_addr;
           proxy_pass http://127.0.0.1:8800;
           expires      3024010s;

           }

           location ~ /purge(/.*)
           {
            #设置只允许指定的IP或IP段才可以清除URL缓存。
            allow            127.0.0.1;
            deny             all;
            proxy_cache_purge    cache_go   $host$1$is_args$args;
           }

     Purge 模块是用来清除缓存的,首先下载安装 Puerge 模块。

    下载 Purge 模块:
    wget http://labs.frickle.com/files/ngx_cache_purge-1.2.tar.gz

     解压:
    tar -zxvf ngx_cache_purge-1.2.tar.gz

     再编译前先使用如下命令查看 nginx 的编译选项:
    复制代码 代码如下:
    /home/nginx/sbin/nginx -V
    nginx version: xxxx
    TLS SNI support enabled
    configure arguments: --prefix=/home/nginx-1.2.8 --with-pcre=../pcre-8.31 --with-zlib=../zlib-1.2.3 --with-openssl=../openssl-1.0.0d --with-http_ssl_module --with-http_stub_status_module --without-mail_pop3_module --without-mail_imap_module --without-mail_smtp_module --add-module=../ngx_cache_purge-1.5 --add-module=../perusio-nginx-http-concat-321e344 --add-module=../ngx_http_vipshop_hostname_filter --with-ld-opt=-static