当前位置 主页 > 服务器问题 > win服务器问题汇总 > 最大化 缩小

    win2008 iis7/iis7.5下最简单最强安装多版本PHP支持环境

    栏目:win服务器问题汇总 时间:2018-08-01 13:59

    这篇文章主要介绍了利用PHP Manager,windows 2008 R2 IIS7.5安装多版本PHP环境的方法,需要的朋友可以参考下

    利用PHP Manager,windows 2008 R2 IIS7.5安装多版本PHP环境

    个人对在windows 2008 R2上,在iis环境中配置安装php环境实践中的注意点:

    1、如需要在服务器上配置mysql的话,在配置php环境前先安装mysql。(根据自己的需求,下载相应的mysql版本)

        mysql安装配置步骤请查看://www.jb51.net/article/39188.htm

    sqlserver 2008安装://www.jb51.net/article/30243.htm

    win2008 r2安装sqlserver 2008需要注意的是,iis好像要安装asp.net与.net组件,否则容易出现问题。当然因为服务器环境的配置问题,都可以搜索相关的错误提示,脚本之家之前都整理过相关的解决方法。

    2、下载php版本文件包,在C盘下创建php文件夹,将文件包中的内容解压到该文件夹下。(可将多版本的php存放在该文件夹下)

    3、下载安装PHP Manager(http://phpmanager.codeplex.com/releases/view/69115),安装完后,这时在iis管理界面中就会多一个PHP Manager管理选项。


    下来就不需要自己在修改php.ini文件,配置php,只需利用PHP Manager来选择需要的php版本中php-cgi.exe就ok了。


    详细的操作步骤请查看下面的内容:

    法一:

    最近调试程序,要在PHP5.2和5.3之间换来换去,而习惯了windows下的开发,就琢磨怎么在iis下安装多版本支持,赫然发现其实微软都为我们准备了好工具。

     

    微软对PHP的支持越来越强,这点在IIS7中体现明显,不但有FastCgi的大力支持,还为PHP的管理专门增加了个PHP Manager。有了这个东东,在windows环境下基于iis7安装PHP简直是易如反掌。

    虽然现在PHP5.3已经出来很久,但许多开源的PHP程序都不是很好支持它,还是PHP5.2为主流。有了PHP Manager这个好东西,在iis下安装多个版本的PHP也变得非常容易。

    具体步骤如下:

    1. 在微软的网站上下载PHP Manager(http://phpmanager.codeplex.com/releases/view/69115),双击安装。这时在iis管理界面中就会多一个PHP Manager管理选项。

    点击查看原图
    点击查看原图

    2. 从PHP官网上下载windows版本的PHP程序。因为采用FastCgi模式运行,所以最新的5.2.17和5.3.8都选择下载nts(非线程安全)的zip版本。下载下来后,找个地方分别解压缩,例如分别放在C:\PHP下的5.2和5.3目录下。

    官方下载地址:http://museum.php.net/php5/

    3. 进入IIS管理界面,双击PHP Manager,选择Register New PHP Version,这是弹出一个选择框,选择5.2版本目录下的php-cgi.exe文件,确认。再此点击Register New PHP Version,选择5.3版本目录下的php-cgi.exe文件,确认后,多版本的环境就搭建好了。简单吧。

    点击查看原图

     

    需要用到那个PHP版本,就点击change PHP version选择需要的版本即可。要检验是否设置好,还可以点旁边的check phpinfo()来查看相应PHP设置信息。

    点击查看原图